Roteamento Baseado em Política

Categoria: Roteamento Avançado Publicado: Quinta, 20 Março 2014 Escrito por Celso Rabelo

 Extraído do site da Cisco, ver original

Índice analítico

Configurando o roteamento baseado em política

Policy-Based Routing Lista de Tarefas de Configuração

Ativando PBR

Ativando PBR Fast-Switched

Ativando PBR local

Ativando PBR-Switched CEF

Exemplos Policy-Based Routing Configuração

Igualdade de Acesso Exemplo

Diferentes Próxima Hops Exemplo


Configurando o roteamento baseado em política


Este capítulo descreve as tarefas para configurar o roteamento baseado em políticas (PBR) em um roteador.

Para obter informações conceituais completa sobre esse recurso, consulte a seção "o roteamento baseado em política" no capítulo " Classificação Overview "neste livro.

Para uma descrição completa da PBR comandos neste capítulo, consulte o Cisco IOS Quality of Service Solutions Referência de Comandos. Para localizar a documentação de outros comandos que aparecem neste capítulo, use o índice principal referência de comando ou pesquisar online.

Para identificar a plataforma de hardware ou software a informação da imagem associada a um recurso, use o recurso Navigator em Cisco.com para procurar informações sobre o recurso ou consulte as notas de versão do software para uma versão específica. Para mais informações, consulte o "Identificar plataformas suportadas" na seção "Usando o Cisco IOS Software" capítulo deste livro.

Policy-Based Routing Lista de Tarefas de Configuração

Para configurar PBR, executar as tarefas descritas nas seções seguintes. A tarefa na primeira seção é necessária; as tarefas nas seções restantes são opcionais.

  Ativando PBR (Obrigatório)

  Ativando Fast-Switched PBR (Opcional)

  Ativando PBR local (Opcional)

  Ativando CEF-Switched PBR (Opcional)

Veja no final deste capítulo para a seção " Exemplos de Configuração de Roteamento Baseado em Políticas . "

Ativando PBR

Para habilitar PBR, você deve criar um mapa da rota que especifica os critérios de correspondência ea ação resultante, se todas as cláusulas jogo sejam cumpridas. Então, você deve habilitar o PBR para esse mapa da rota em uma interface específica. Todos os pacotes que chegam na interface especificada combinando as cláusulas jogo estará sujeito a PBR.

Para habilitar PBR em uma interface, use os seguintes comandos começam no modo de configuração global:

 

 
Comando
Propósito

Passo 1

Router (config) # route-mapmapa-tag [autorização |negar] [seqüência de número]

Define um mapa de rota para controlar onde os pacotes são emitidos. Este comando coloca o roteador em route-map modo de configuração.

Passo 2

Router (config-route-map) #match comprimento min max

Router (config-route-map) #corresponde ao endereço ip{access-list-number | nome} [... access-list-number |nome]

Especifica os critérios de correspondência.

Embora existam muitos-Mapa de rota de opções de correspondência, aqui você pode especificar apenas o comprimento e / ou endereço IP.

  comprimento corresponde ao nível 3 comprimento do pacote.

  endereço IP corresponde ao endereço IP de origem ou de destino que é permitido por uma ou mais listas de acesso padrão ou estendida.

Se você não especificar um comando de partida, o roteiro se aplica a todos os pacotes.

Passo 3

Router (config-route-map) #precedência set ip [número |nome]

Router (config-route-map) #df set ip

Router (-map config-route) #set ip vrf nome vrf_

Router (config-route-map) #set ip next-hop endereço IP[... ip-address]

Router (config-route-map) #set ip next-hop recursivaip-address [... ip-address]

Router (config-route-map) #interface do conjunto

interface de número do tipo de interface [... número do tipo]

Router (config-route-map) #set ip default do próximo salto ip-address [... ip-address]

Router (config-route-map) #interface de configuração padrão interface de número do tipo de interface [...tipo ... number]

Especifica a ação (s) para assumir os pacotes que correspondem aos critérios. Pode especificar qualquer ou todas as seguintes características:

  precedência: Define valor de precedência no cabeçalho IP. Você pode especificar o número de precedência ou nome.

  df: Define o bit `Não Fragmento" (DF) no cabeçalho IP.

  VRF: Define a instância VPN Routing e Transmissão (VRF).

  do próximo salto: Define próximo salto para que a rota do pacote.

  next-hop recursivas: Define próximo salto para o qual a rota que o pacote se o hop é um roteador que não é adjacente.

  Interface: Conjuntos de interface de saída, para o pacote.

  padrão do próximo salto: Define próximo salto para o qual a rota que o pacote se não houver uma rota explícita para este destino.

  interface padrão: Define interface de saída para o pacote se não houver uma rota explícita para este destino.

Passo 4

Router (-map config-route) #interface do tipo de interface interface de número

Especifica a interface, e coloca o roteador em modo de configuração de interface.

Passo 5

Router (config-if) # ip política route-map mapa-tag

Identifica o mapa da rota a ser usada para PBR. Uma interface pode ter apenas um mapa de rotas tag, mas você pode ter várias entradas do mapa de rotas, cada um com seu próprio número de seqüência. As entradas são avaliadas em ordem de seus números de seqüência até que o primeiro jogo ocorre. Caso não ocorra nenhum jogo, os pacotes são roteados como de costume.

 

Os comandos do conjunto pode ser usado em conjunto com o outro. Elas são avaliadas na ordem mostrada na etapa 3 na tabela de tarefas anterior. A próxima hop utilizável implica uma interface. Uma vez que o roteador local encontra um próximo hop e uma interface utilizável, ele encaminha o pacote.


Nota  Ativando PBR desativa comutação rápida de todos os pacotes que chegam nesta interface.


Se você quiser PBR ser fast-comutada, consulte a seção " Ativando Fast-Switched PBR ", que se segue.

Ativando PBR Fast-Switched

IP PBR agora pode ser fast-comutada. Antes da Cisco IOS versão 12.0, PBR só poderia ser comutada por processo, o que significa que na maioria das plataformas a taxa de comutação foi de aproximadamente 1.000 a 10.000 pacotes por segundo. Esta velocidade não foi rápido o suficiente para muitas aplicações. Os usuários que precisam PBR para ocorrer em velocidades mais rápidas podem agora implementar PBR sem abrandar o roteador.

Fast-comutada PBR suporta todos os comandos do fósforo ea maioria dos comandos de ajuste, com as seguintes restrições:

  configuração padrão de IP do próximo salto e definir comandos da interface padrão não são suportados.

  O comando set interface é suportado apenas por links ponto-a-ponto, a menos que exista uma entrada de cache de rota usando a mesma interface especificada no comandoset interface no mapa da rota. Além disso, no nível do processo, a tabela de roteamento é consultada para determinar se a interface está em um caminho razoável para o destino. Durante a comutação rápida, o software não faz esta verificação. Em vez disso, se o pacote corresponde, o software cegamente encaminha o pacote para a interface especificada.

PBR deve ser configurado antes de configurar fast-comutada PBR. Troca rápida de PBR é desabilitado por padrão. Para habilitar-switched rápido PBR, use o seguinte comando no modo de configuração da interface:

 

 
Comando
Propósito

Router (config-if) # ip route-cache política

Permite a comutação rápida de PBR.


 

Para exibir as entradas de cache no cache de rota política, use o comando show ip política de cache. Para mostrar que mapa de rotas é associado com a interface, use o comandoshow ip política.

Ativando PBR local

Os pacotes que são gerados pelo roteador normalmente não são encaminhados para as políticas. Para habilitar PBR local para tais pacotes, indicar qual mapa de rota o roteador deve usar usando o seguinte comando no modo de configuração global:

 

 
Comando
Propósito

Router (config) # ip política local route-map mapa-tag

Identifica o mapa da rota a ser usada para PBR local.


 

Todos os pacotes originários no roteador será então sujeito a PBR local.

Use o comando show ip política local para exibir o mapa da rota utilizada para PBR local, se houver.

Ativando PBR-Switched CEF

A partir de Cisco IOS versão 12.0, PBR é suportado na Cisco Express Forwarding (CEF) a mudança de caminho. CEF-switched PBR tem melhor desempenho do que PBR comutação de rápido e, portanto, é a melhor maneira de executar PBR em um roteador.

Nenhuma configuração especial é necessária para permitir PBR-switched CEF. Ele é ativado por padrão assim que você ativar CEF e PBR no roteador.


Nota  O comando ip route-cache política é estritamente para PBR comutação de rápido e, portanto, não é necessário para PBR CEF-comutada.


Exemplos Policy-Based Routing Configuração

As seções a seguir fornecem exemplos de configuração PBR:

  Igualdade de Acesso Exemplo

  Diferentes Próxima Hops Exemplo

Para obter informações sobre como configurar o roteamento baseado em políticas, consulte a seção "Encaminhamento de lista de tarefas de configuração baseado em política"neste capítulo.


Nota  Os exemplos apresentados a seguir envolvem a utilização do comando de lista de acesso (ACL). A palavra-chave de registro não deve ser usado com esse comando no roteamento baseado em políticas (PBR), porque o registo não é suportada no nível de interrupção para ACLs.


Igualdade de Acesso Exemplo

O exemplo a seguir fornece duas fontes com acesso igual a dois prestadores de serviços diferentes. Os pacotes que chegam na interface assíncrona 1 do 209.165.200.225 fonte são enviados para o roteador em 209.165.200.228 se o roteador não tem rota explícita para o destino do pacote. Os pacotes que chegam do 209.165.200.226 fonte são enviados para o roteador em 209.165.200.229 se o roteador não tem rota explícita para o destino do pacote. Todos os outros pacotes para que o roteador não tem nenhuma rota explícita para o destino são descartados.

  access-list 1 permit 209.165.200.225
  access-list 2 autorização 209.165.200.226
  !
  interface assíncrona 1
  route-map política ip de acesso igual
  !
  route-map autorização de acesso igual a 10
  endereço de correspondência ip 1
  conjunto padrão ip 209.165.200.228 do próximo salto
  route-map autorização de acesso igual a 20
  endereço ip jogo 2
  conjunto padrão ip 209.165.200.229 do próximo salto
  route-map autorização de acesso igual 30
  null0 set interface padrão

Diferentes Próxima Hops Exemplo

O exemplo a seguir ilustra como a rota de tráfego de diferentes fontes para diferentes lugares (nos próximos lúpulo), e como definir o bit Precedência no cabeçalho IP. Os pacotes que chegam de fonte 209.165.200.225 são enviados para o próximo salto em 209.165.200.227 com a precedência bit definido para prioridade; pacotes que chegam a partir da fonte 209.165.200.226 são enviados para o próximo salto em 209.165.200.228 com a precedência bit definido para crítica.

  access-list 1 permit 209.165.200.225
  access-list 2 autorização 209.165.200.226
  !
  interface ethernet 1
  route-map política ip Texas
  !
  route-map Texas permitir 10
  endereço de correspondência ip 1
  definir a prioridade de precedência ip
  set ip next-hop 209.165.200.227
  !
  route-map Texas permitir 20
  endereço ip jogo 2
  definir precedência ip crítico
  set ip next-hop 209.165.200.228
Acessos: 3829