Ativando autenticação de roteadores e switches com radius

Categoria: Segurança Publicado: Terça, 08 Abril 2014 Escrito por Celso Rabelo

Usando servidor de radius para autenticar usuários em roteadores ou switches

1) criar senha de enable

router(config)#enable secret SENHA

2) ativar aaa no roteador/switch

router(config)#aaa new model

3) indicar o local de autenticação para 1 servidor radius

router(config)#aaa authentication login default group radius

4) associar um servidor de radius para o processo de autendicação

router(config)#radius-server host IP_server

5) asssociar palavra usada pelo servidor de radius

router(config)#radius-server key PALAVRA

6) configurar acesso a linhas de console e vty

router(config-line)@login authentication default

 

Exemplo:

 

hostname Router

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

aaa new-model

aaa authentication login default group radius 

interface FastEthernet0/0

 ip address 10.0.0.1 255.255.255.0

 duplex auto

 speed auto

 no shut

interface FastEthernet0/1

 ip address 192.168.0.1 255.255.255.0

 duplex auto

 speed auto

 no shut

interface Vlan1

 no ip address

 shutdown

ip classless

radius-server host 10.0.0.10 auth-port 1645

radius-server key 12345

line con 0

 login authentication default

line vty 0 4

 login authentication default

line vty 5 15

 login authentication default

!

Artigo Cisco veja aqui

Acessos: 5018